Cisco DHCP Configuration

Reading Time: 2 minutes

DHCPTOPOLOGY

Cisco routers are capable of doing many more things than simply routing packets. In fact, it can operate as a small DHCP server when needed. By no means is it a replacement for your enterprise, centrally managed DHCP server but it does have its applicable scenarios. Lets say you have a branch office that has its own server for any particular reason. Maybe it is a local file share for an engineering departments CAD program and rather than having all file traffic from opens and saves traverse the WAN during the day, you simply run backs of that server across the WAN at night. The problem with this is that file share likely has a static IP address. If your WAN link goes down, and your clients attempt to renew their lease, they will end up on the good ol’ 169.254.0.0 network. This means they can no longer talk to that server and you’ve got a department sitting idle with resources at their own building they cannot access. Step in the branch office router, hero to the DHCP disablement. By having the DHCP server located on the branch office router, the WAN link can fail and the engineering department, as well as their local server, have no care in the world (aside from any corporate data and servers they may need access too). Their leases can renew, they stay on the network with the server, and they can continue chugging alone on their tasks until the WAN link is re-established. Below is the configuration for the example above. Two vlans are running in the branch office with the router handing out leases for both.

R1

hostname R1
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.11.12.1
ip dhcp excluded-address 172.16.0.1
!
ip dhcp pool VLAN10
   network 10.11.12.0 255.255.255.0
   default-router 10.11.12.1
   dns-server 8.8.8.8
   lease 10 12 30
!
ip dhcp pool VLAN20
   network 172.16.0.0 255.255.255.0
   default-router 172.16.0.1 255.255.255.0
   dns-server 8.8.8.8
   option 150 ip 192.168.1.1
   lease 10 12 30
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 description VLAN 10 SubInt
 encapsulation dot1Q 10
 ip address 10.11.12.1 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/0.20
 description VLAN 20 SubInt
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.255.0
 no snmp trap link-status
!
end
Share this article:

Permanent link to this article: https://www.packetpilot.com/cisco-dhcp-configuration/

Leave a Reply

Your email address will not be published.